summaryrefslogtreecommitdiff
path: root/ayafs/Cargo.toml
diff options
context:
space:
mode:
authorChuyan Zhang <me@zcy.moe>2023-11-30 02:15:06 -0800
committerChuyan Zhang <me@zcy.moe>2023-11-30 02:15:06 -0800
commit1eac97eea4ec0bcef0be061a2cba93a584355283 (patch)
treed98fb1f6e3811286a0733c9df21e467590635ad2 /ayafs/Cargo.toml
parentb3db8a5a710aa0890c80241ffb3fd9792bf1cbe7 (diff)
downloadmyfs-1eac97eea4ec0bcef0be061a2cba93a584355283.tar.gz
myfs-1eac97eea4ec0bcef0be061a2cba93a584355283.zip
Add real disk i/o, add mkfs.aya (not yet implemented)
Diffstat (limited to 'ayafs/Cargo.toml')
-rw-r--r--ayafs/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/ayafs/Cargo.toml b/ayafs/Cargo.toml
new file mode 100644
index 0000000..43585e0
--- /dev/null
+++ b/ayafs/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "ayafs"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+and_then_some = "1.0.0"
+bitflags = "2.4.1"
+clap = { version = "4.4.10", features = ["derive"] }
+env_logger = "0.10.1"
+fuser = "0.14.0"
+indexmap = "2.1.0"
+libc = "0.2.150"
+log = "0.4.20"
+lru = "0.12.1"
+users = "0.11.0"