summaryrefslogtreecommitdiff
path: root/ayafs-core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ayafs-core/Cargo.toml')
-rw-r--r--ayafs-core/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/ayafs-core/Cargo.toml b/ayafs-core/Cargo.toml
new file mode 100644
index 0000000..8e12bf5
--- /dev/null
+++ b/ayafs-core/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "ayafs-core"
+version = "0.1.0"
+edition = "2021"
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[lib]
+name = "aya"
+path = "src/lib.rs"
+
+[[bin]]
+name = "ayafs_cli"
+path = "src/bin/main.rs"
+
+[dependencies]
+and_then_some = "1.0.0"
+bitflags = "2.4.1"
+clap = { version = "4.4.10", features = ["derive"] }
+env_logger = "0.10.1"
+fuser = "0.14.0"
+indexmap = "2.1.0"
+libc = "0.2.150"
+log = "0.4.20"
+lru = "0.12.1"
+users = "0.11.0"